Shopify API Outage

Incident Report for PushOwl

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 10:52 IST

Update

Customers attempting to create a new Shopify integration or perform actions that rely on the Shopify API may encounter errors. Additionally, customers with existing Shopify integrations could experience delays in data synchronization.

The disruption is related to a partial outage affecting an upstream service. Our team is actively monitoring the incident.

For updates on the upstream service incident, please refer to Shopify’s status page:

https://www.shopifystatus.com/

We will continue to share updates as more details become available.
Posted Jun 03, 2026 - 20:23 IST

Identified

We have identified the root cause (Shopify API outage) of the issue and are beginning to see signs of recovery. Our team continues to closely monitor the situation and will provide another update as soon as more information becomes available.
Posted Jun 03, 2026 - 20:19 IST
This incident affected: Shopify API & Mobile.